Donation

Help us to pay our server!
(: Consider a donation :)



Social Media

  • Facebook
  • Google+

Latest Posts

Topic: Lob und Frage

kaputtnik
Avatar
Joined: 2013-02-18, 20:48
Posts: 1421
Ranking
One Elder of Players
Location: Germany
Posted at: 2018-08-12, 17:03

Fang vlt mit dem sound data/sound/smiths/smith_xx.ogg und toolsmith_xx.ogg an. Das stört, zumindest mich, am meisten face-smile.png


Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 695
Ranking
One Elder of Players
Location: Saxony, GER
Posted at: 2018-08-12, 18:03

kaputtnik wrote: Verzichten möchte ich aber auf keinen Fall auf die Geräusche, schon gar nicht auf das Vogelgezwitscher face-smile.png

Was hälst du von der Idee, parallel zu Widelands Vogelgezwitscher-Audiodateien zu hören? face-wink.png

tada23 wrote:

@WorldSavior

Also z.B. diesen ständigen "timba" Ausruf zumindest reduzieren, oder ganz wegnehmen? Das haben wir schon - in der Entwicklungsversion ist er schon weg

Rufen die Holzfäller jetzt überhaupt nicht mehr,

Zum Glück nicht face-smile.png

oder habt ihr was anderes genommen?

Ja, das Geräusch eines stürzenden Baumes.


*insert phrase about the necessity of saving the world here*

Top Quote
tada23
Avatar
Joined: 2018-08-11, 11:51
Posts: 33
Ranking
Pry about Widelands
Location: Berlin
Posted at: 2018-08-13, 09:47

Guten Morgen.

Habe mich bei launchpad registriert, und werde jetzt mal die ersten Sounds bearbeiten. Was muss ich dann tun? Kann ich immer wieder zwischendurch neue/veränderte Sounds hinzufügen, oder muss ich alle sammeln und zusammen ... ähh an einen Käfer hängen/hochladen

(wie auch immer das funktionieren mag face-smile.png ??)

Wenn ich das richtig verstehe ist launchpad eine Cloud (ubuntu one)?

LG

tada


Top Quote
hessenfarmer
Avatar
Joined: 2014-12-11, 23:16
Posts: 342
Ranking
Tribe Member
Location: Bavaria
Posted at: 2018-08-13, 09:56

Wenn du eingeloggt bist kannst du unter https://bugs.launchpad.net/widelands einen neuen Bugreport erstellen. An diesen Bugreport kannst du dann Anhänge (deine geänderten Sounds) anhängen. Einer von den Entwicklern kann diese dann in einen neuen Zweig integrieren.


Top Quote
GunChleoc
Avatar
Joined: 2013-10-07, 15:56
Posts: 2487
Ranking
One Elder of Players
Location: RenderedRect
Posted at: 2018-08-13, 10:21

Wir haben inzwischen auch ein Wusch für die Bäume. Seit Build 19 hat sich mit den Sounds so einiges geändert, Du mußt also unbedingt eine aktuelle Entwicklerversion haben. Wenn Du nicht selber kompilieren willst, geht das nur über die widelands-daily ppa. Das geht so:

  • Aktuelle Widelands-Version deinstallieren, entweder per user interface oder per sudo add-apt-repository --remove ppa:widelands-dev/widelands-daily

  • Dann folgende Komanndozeilen/Terminal-Befehle ausführen:

sudo apt autoremove
sudo add-apt-repository ppa:widelands-dev/widelands-daily
sudo apt-get update
sudo apt-get install widelands

https://wl.widelands.org/wiki/Download/#ubuntu-recent-releases-and-derivatives-like-linux-mint-17

Das ist die Anleitung für Ubuntu, hoffentlich funktioniert es auch unter Debian.

Edited: 2018-08-13, 10:22
Top Quote
tada23
Avatar
Joined: 2018-08-11, 11:51
Posts: 33
Ranking
Pry about Widelands
Location: Berlin
Posted at: 2018-08-13, 10:39

@hessenfarmer

Danke.

Würde aber gern vorher jemanden "reinhören" lassen, ob das überhaupt ok ist, was ich da mache. Vielleicht liegen ja unsere Vorstellungen oder Ansprüche auch ganz weit auseinander. Möcht schon vermeiden, stundenlang Sounds zu editieren, und niemanden gefällt es ... face-smile.png

Ausserdem hätte ich da noch die ein oder andere Frage zur grundsätzlichen "Mechanik" im Spiel, weil ich ja kein Programmierer bin. An wen kann ich mich da wenden? Oder soll ich die Fragen einfach weiter hier im Forum stellen?

Edited: 2018-08-13, 10:58
Top Quote
tada23
Avatar
Joined: 2018-08-11, 11:51
Posts: 33
Ranking
Pry about Widelands
Location: Berlin
Posted at: 2018-08-13, 10:45

@GunChleoc

Kein Problem, aber kann ich damit auch ... spielen? face-smile.png

Will ja schliesslich nicht nur arbeiten face-wink.png


Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 695
Ranking
One Elder of Players
Location: Saxony, GER
Posted at: 2018-08-13, 11:41

tada23 wrote:

Ausserdem hätte ich da noch die ein oder andere Frage zur grundsätzlichen "Mechanik" im Spiel, weil ich ja kein Programmierer bin. An wen kann ich mich da wenden? Oder soll ich die Fragen einfach weiter hier im Forum stellen?

Du kannst die Fragen einfach im Forum stellen, oder davor das Forum durchsuchen und herausfinden, ob es die Antworten schon gibt.

tada23 wrote:

Kein Problem, aber kann ich damit auch ... spielen? face-smile.png

Will ja schliesslich nicht nur arbeiten face-wink.png

Ja, und wie! Die Entwicklerversion ist build18 meilenweit voraus und bietet auch gegenüber b19 sehr viele Vorteile.


*insert phrase about the necessity of saving the world here*

Top Quote
tada23
Avatar
Joined: 2018-08-11, 11:51
Posts: 33
Ranking
Pry about Widelands
Location: Berlin
Posted at: 2018-08-13, 12:36

Habe versucht die daily Version wie von GunChleoc beschrieben zu installieren, bekomme aber folgende Fehlermeldung:

Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass Sie eine unmögliche Situation angefordert haben oder, wenn Sie die Unstable-Distribution verwenden, dass einige erforderliche Pakete noch nicht erstellt wurden oder Incoming noch nicht verlassen haben. Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten: widelands : Hängt ab von: libboost-regex1.67.0 ist aber nicht installierbar Hängt ab von: libboost-system1.67.0 ist aber nicht installierbar Hängt ab von: libc6 (>= 2.27) aber 2.24-11+deb9u3 soll installiert werden Hängt ab von: libicu60 (>= 60.1-1~) ist aber nicht installierbar Hängt ab von: libsdl2-2.0-0 (>= 2.0.8) aber 2.0.5+dfsg1-2 soll installiert werden Hängt ab von: libsdl2-image-2.0-0 (>= 2.0.2) aber 2.0.1+dfsg-2+deb9u1 soll installiert werden Hängt ab von: libsdl2-mixer-2.0-0 (>= 2.0.2) soll aber nicht installiert werden E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Könnte es damit zusammenhängen, dass ich die "normale" Version mit apt-get install/remove installiert und entfernt habe?


Top Quote
GunChleoc
Avatar
Joined: 2013-10-07, 15:56
Posts: 2487
Ranking
One Elder of Players
Location: RenderedRect
Posted at: 2018-08-13, 15:31

Sieht so aus, als ob Ubuntu auf einer neueren Version der Pakete ist als Deine Debian-Installation. Die ist aber auch neu, schon komisch. Wahrscheinlich mußt Du Dir erstmal die Pakete über den Debian-Paketmanager manuell zusammensammeln.

Stell Deine Fragen weiter hier im Forum, da hast Du die beste Chance, daß jemand die Antwort weiß.


Top Quote