Latest Posts

Topic: Unable to join multiplayer lobby

WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 792
Ranking
One Elder of Players
Posted at: 2018-08-03, 11:51

When I try to login in the metaserver, it doesn't work and Widelands says "Error! The Metaserver hasn't responded"

My version: Build19

Is this problem temporarily or caused by a change?


“It's a threat to our planet to believe that someone else will save it.” - Robert Swan

Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 792
Ranking
One Elder of Players
Posted at: 2018-08-04, 13:27

Update: Now I also have the problem with the development version.

But I found an easy way to solve it: I just have to change my username a bit when I log in, for example with a number after the username.


“It's a threat to our planet to believe that someone else will save it.” - Robert Swan

Top Quote
stonerl
Avatar
Joined: 2018-07-30, 00:03
Posts: 91
Ranking
Likes to be here
Location: Earth
Posted at: 2018-08-04, 13:55

Well, it seems that one cannot log in with a registered username.

Edited: 2018-08-04, 15:17
Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 792
Ranking
One Elder of Players
Posted at: 2018-08-04, 14:13

stonerl wrote:

Well, it seems that one cannot log in with an registered username.

True - or with a non-registered username which has been currently used, for example "WorldSavior7". So I have to use "WorldSavior8" and so on...


“It's a threat to our planet to believe that someone else will save it.” - Robert Swan

Top Quote
kaputtnik
Avatar
Joined: 2013-02-18, 20:48
Posts: 1503
Ranking
One Elder of Players
Location: Germany
Posted at: 2018-08-04, 17:07

There is a bug report created.


Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 792
Ranking
One Elder of Players
Posted at: 2018-08-08, 13:41

Good news: Joining the Lobby with b19 works fine again.


“It's a threat to our planet to believe that someone else will save it.” - Robert Swan

Top Quote
Notabilis
Avatar
Joined: 2016-11-03, 20:37
Posts: 23
Ranking
Pry about Widelands
Posted at: 2018-08-09, 00:41

Sorry for that. face-confused.png

It seems as if there was some problems with the IRC bridge and a buffer run full, leading to blocking code when trying to send the "logged in" message. But this does not explain the other effects you encountered. I restarted the metaserver so it should be fine for now while I try to figure out what went wrong.


Top Quote
WorldSavior
Avatar
Joined: 2016-10-15, 04:10
Posts: 792
Ranking
One Elder of Players
Posted at: 2018-08-09, 01:20

Notabilis wrote:

Sorry for that. :-/

What? You are sorry because it works again? face-wink.png

And would you like to play a match? It's nice to see you in the lobby after that long time...


“It's a threat to our planet to believe that someone else will save it.” - Robert Swan

Top Quote