Currently Online

Latest Posts

Topic: Very Slow Pointer Speed on Raspberry Pi 3 Running Raspian Stretch

User
Avatar
Joined: 2017-09-28, 20:37
Posts: 5
Ranking
Just found this site
Posted at: 2017-09-28, 20:48

Hello,

I have previously played Widelands on the raspberry pi and I remember having to disable OpenGL or else the pointer would lag a lot

However I cannot seem to find the advanced/extended options in the options

Is there another way to disable OpenGL rendering or do I need to do something else.

I'd be REALLY grateful if someone could help me. face-smile.png


Top Quote
kaputtnik
Avatar
Joined: 2013-02-18, 20:48
Posts: 1648
Ranking
One Elder of Players
Location: Germany
Posted at: 2017-09-28, 22:47

Hi User and welcome face-smile.png

Since build 19 (od Build 18?) OpenGL is needed for playing widelands. So it could not be disabled anymore.


Top Quote
User
Avatar
Joined: 2017-09-28, 20:37
Posts: 5
Ranking
Just found this site
Posted at: 2017-10-02, 22:42

Oh OK but then how can I run the game on my Raspberry Pi are there any setting you recommenced changing and it is possible to go back a version?


Top Quote
Tibor
Joined: 2009-03-23, 23:24
Posts: 1217
Ranking
One Elder of Players
Location: Slovakia
Posted at: 2017-10-03, 07:58

It might be possible to track down when opengl was made obligatory, you would need to go over commit messages of the trunk and identify the commit and use and compile previous one by yourselves


Top Quote
User
Avatar
Joined: 2017-09-28, 20:37
Posts: 5
Ranking
Just found this site
Posted at: 2017-10-03, 16:55

Do you think it is still possible to play widelands smoothly on the pi and if so would you know how much memory(RAM) to allocate to the GPU?


Top Quote
Tibor
Joined: 2009-03-23, 23:24
Posts: 1217
Ranking
One Elder of Players
Location: Slovakia
Posted at: 2017-10-03, 21:06

Sorry, I have no idea....


Top Quote
User
Avatar
Joined: 2017-09-28, 20:37
Posts: 5
Ranking
Just found this site
Posted at: 2017-10-06, 23:20

Ah, No problem face-smile.png


Top Quote
User
Avatar
Joined: 2017-09-28, 20:37
Posts: 5
Ranking
Just found this site
Posted at: 2017-10-07, 18:57

kaputtnik wrote:

Hi User and welcome face-smile.png

Since build 19 (od Build 18?) OpenGL is needed for playing widelands. So it could not be disabled anymore.

Hmm so how can I play widelands on the raspberry pi smoothly? Maybe I need to allocate more RAM to the GPU? Or is the pi no longer a viable option to play widelands?

Thanks


Top Quote
GunChleoc
Avatar
Joined: 2013-10-07, 15:56
Posts: 2811
Ranking
One Elder of Players
Location: RenderedRect
Posted at: 2017-10-09, 21:11

I'm away from my Linux machine right now, so I can't do any profiling. We have no data on this.

OpenGL can still be switched off with Build 18 in the Advanced Options. https://launchpad.net/widelands/build18/build-18

Edited: 2017-10-09, 21:12

Busy indexing nil values

Top Quote